Концепция системы 1С:Предприятие 7.7. Метаданные, Основные понятия

Концепция системы 1С:Предприятие 7.7

1С:Предприятие является универсальной системой автоматиза­ции деятельности предприятия. За счет своей универсальности сис­тема 1С:Предприятие может быть использована для автоматизации самых разных участков экономической деятельности предприятия: учета товарных и материальных средств, взаиморасчетов с контр­агентами, расчета заработной платы, расчета амортизации основных средств, бухгалтерского учета по любым разделам и т. д.

Конфигурируемость

Основной особенностью системы 1С:Предприятия является ее конфигурируемость. Собственно система 1С:Предприятие представ­ляет собой совокупность механизмов, предназначенных для манипу­лирования различными типами объектов предметной области. Кон­кретный набор объектов, структуры информационных массивов, ал­горитмы обработки информации определяет конкретная конфигура­ция. Вместе с конфигурацией система 1С:Предприятие выступает в качестве уже готового к использованию программного продукта, ориентированного на определенные типы предприятий и классы ре­шаемых задач.

Конфигурация создается штатными средствами системы. Конфи­гурация обычно поставляется фирмой «1С» в качестве типовой для конкретной области применения, но может быть изменена, дополне­на пользователем системы, а также разработана заново.

Подробнее

Метаданные платформы 1С Предприятие 7.7 – Описание методов. Помощник

Метаданные платформы 1С Предприятие 7.7 – Описание методов. Помощник

Методы Синтаксис Помощника

Методы метаданных
Выбран()
Синтаксис:
Выбран()
Назначение:
Проверяет позиционирован ли объект типа “Метаданные” на конкретном объекте метаданных или нет. Возвращает число: 1 – объект соответствует объекту метаданных (спозиционирован), 0 – если не соответствует.
Пример:
Функция ВернутьРеквизитЦена()
Если Метаданные.Справочники(“Номенклатура”).Выбран()=0 Тогда
Сообщить(“Нет справочника Номенклатура”);
Возврат “”;
Если Метаданные.Справочники(“Номенклатура”).Реквизит(“Цена”).Выбран()=0 Тогда
Сообщить(“У справочника Номенклатура нет реквизита цена”);
Возврат “”;
Иначе
Возврат Метаданные.Справочники(“Номенклатура”).Реквизит(“Цена”);
КонецЕсли;
КонецЕсли;
КонецФункции
Родитель()
Синтаксис:
Родитель()
Назначение:
Возвращает объект метаданных, которому подчинен данный объект.
Пример:
Рекв=ВернутьРеквизитЦена();
Если ПустоеЗначение(Рекв)=0 Тогда
Сообщить(“Реквизит относится к “+Рекв.Родитель())
КонецЕсли;
ПолныйИдентификатор()
Синтаксис:
ПолныйИдентификатор()
Назначение:
Возвращает полный идентификатор объекта (идентификатор объекта с идентификаторами его родителей через точку).
Пример:
Рекв=ВернутьРеквизитЦена();
Если ПустоеЗначение(Рекв)=0 Тогда
Сообщить(“Это “+Рекв.ПолныйИдентификатор());
КонецЕсли;
Представление()
Синтаксис:
Представление()
Назначение:
Возвращает строковое значение представления объекта (синоним объекта, а если он не задан, то идентификатор).
Пример:
Рекв=ВернутьРеквизитЦена();
Если ПустоеЗначение(Рекв)=0 Тогда
Сообщить(“Представление “+Рекв. Представление());
КонецЕсли;
ДлинаПредставленияЗначения(,,)
Синтаксис:
ДлинаПредставленияЗначения(,,)
Назначение:
Возвращает длину представления значения. Данный метод может использоваться, например, для определения ширины столбца в универсальных отчетах, выводящих данные объектов различных видов.
Параметры:
<Мин> – необязательный параметр. Метод не будет возвращать значение меньше указанной в данном параметре величины.
<Макс> – необязательный параметр. Метод не будет возвращать значение больше указанной в данном параметре величины.
<ДлПоУмолч> – необязательный параметр. Метод будет возвращать данную величину для метаданных, для которых длина представления не определена. Параметр задает длину для типов данных, таких как Справочник неопределенного типа и аналогичных, у которых не определена длина.
Пример:
Рекв=ВернутьРеквизитЦена();
Если ПустоеЗначение(Рекв)=0 Тогда
Сообщить(“Длина представления “+Рекв.ДлинаПредставленияЗначения(,,));
КонецЕсли;

Так же есть еще две функции для списочных объектов

Методы атрибутов метаданных, содержащих список ссылок
Количество()
Синтаксис:
Количество()
Назначение:
Возвращает количество ссылок в списке.
Пример:
Для Инд=1 по Метаданные.ГрафаОтбора() Цикл
Графа=Метаданные.ГрафаОтбора(Инд);
Сообщить(“У графы “+ Графа. Количество()+” ссылок”);
КонецЦикла;
Получить()
Синтаксис:
Получить()
Назначение:
Возвращает количество ссылок в списке.
Пример:
Для Инд=1 по Метаданные.ГрафаОтбора() Цикл
Графа=Метаданные.ГрафаОтбора(Инд);
Сообщить(“У графы “+ Графа.Количество()+” ссылок!В том числе:”);
Для Сч=1 по Графа.Количество() Цикл
Сообщить(Графа.Получить(Сч).ПолныйИдентификатор());
КонецЦикла;
КонецЦикла;

Корень Конфигурации

Идентификатор
Метаданные.Идентификатор
Назначение: 
Получить идентификатор конфигурации. Задается в конфигураторе – свойства конфигурации идентификатор.
Возвращаемое значение:
Строка.
ПолныйИдентификатор()
Данный метод описан в метаданных синтаксис помощника. Единственное что можно добавить, что всегда возвращает строку вида “Задача”
Синоним
Метаданные.Синоним
Возвращаемое значение:
Строка.
Комментарий
Метаданные.Комментарий
Возвращаемое значение:
Строка.
Пароль
Метаданные.Пароль
Возвращаемое значение:
0 -Пароля на конфигурации нет
1 -Пароля на конфигурации есть
АвторРазвернутаяИнформация
Метаданные.АвторРазвернутаяИнформация
Возвращаемое значение:
Строка.
АвторКороткаяИнформация
Метаданные.АвторКороткаяИнформация
Возвращаемое значение:
Строка.
Язык
Метаданные.Язык
Возвращаемое значение:
Строка. Язык который определен при создании конфигурации. В русских конфигурациях возращается строка “Русский”
Округление
Метаданные.Округление
Возвращаемое значение:
Строка вида “Окр1_5До2” или “Окр1_5До1” в зависимости от выбранного режима округления. Вполне вероятно, что на других языковых движках строка будет другая
НепосредственноеУдалениеОбъектов
Метаданные.НепосредственноеУдалениеОбъектов
Возвращаемое значение:
0 – Непосредственное удаление объектов запрещено
1 – Непосредственное удаление объектов разрешено
ПолныйЖурнал
Метаданные.ПолныйЖурнал
Возвращаемое значение:
Ссылка на полный журнал документов или же пустое значение, если журнал не определен
ЖурналПодчиненныхДокументов
Метаданные.ЖурналПодчиненныхДокументов
Возвращаемое значение:
Ссылка на журнал подчиненных документов или же пустое значение, если журнал не определен

Подробнее